equired PHP version greater than equal to 5.4.0 AND found version is : 5.3.29 - Softaculous Prestashop not picking up correct php version

You may come across an issue while installing Prestashop via Softaculous regarding not picking up correct php version.

The error would look similar to the error below -

The following errors were found : Required PHP version greater than equal to 5.4.0 AND found version is : 5.3.29

Solution :

1. Modify the file where softaculous is installed on the server -

2. Make a copy of pre_install.php file before you make any changes.

3. Now, add below code and replace $version = phpversion(); with $version = 5.6;

    function __pre_install()

    global $soft, $software, $globals;
    // Your Code to Identify the PHP version
    // E.g
   $version = phpversion();
   define('php_version', $version);

 Give a try to re-install prestashop via Softaculous and this should work for you.
  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

Error:The system experienced the following error when it attempted to install the “OWASP ModSecurity Core Rule Set V3.0”

Issue while installing Comodo's WAF rules in cPanel - Error:The system experienced the following...

A DNS entry for 'domain_name' already exists. You must remove this DNS entry from all servers in the DNS cluster to proceed.

While adding addon domain under cPanel, I was getting error as below - A DNS entry for...

ERROR :Tablespace for table exist. Please DISCARD the tablespace before IMPORT.

// While creating the table from cPanel >> PHPMyAdmin>> SQL, I was getting...

How to setup the root login alert notification email?

Its very important to keep a check on your servers and who logs into the server, From security...

Powered by WHMCompleteSolution