equired PHP version greater than equal to 5.4.0 AND found version is : 5.3.29 - Softaculous Prestashop not picking up correct php version

You may come across an issue while installing Prestashop via Softaculous regarding not picking up correct php version.

The error would look similar to the error below -

The following errors were found : Required PHP version greater than equal to 5.4.0 AND found version is : 5.3.29

Solution :

1. Modify the file where softaculous is installed on the server -
/usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/pre_install.php

2. Make a copy of pre_install.php file before you make any changes.

3. Now, add below code and replace $version = phpversion(); with $version = 5.6;

    function __pre_install()
   {

    global $soft, $software, $globals;
    // Your Code to Identify the PHP version
    // E.g
   $version = phpversion();
   define('php_version', $version);
   }

 Give a try to re-install prestashop via Softaculous and this should work for you.

Was this answer helpful?

 Print this Article

Also Read

Error displaying the error page: The cachelite Cache Storage is not supported on this platform. (Joomla error)

While accessing the Joomla site, I was getting error as - Error displaying the error page: The...

How to change the primary IP address of a WHM/cPanel (centOS/RHEL) based servers?

1. Steps for WHM: I. Log into WHM >> Basic cPanel & WHM Setup II. Change the Primary...

Is it possible to add multiple backup destinations on the cPanel server?

Is it possible to add multiple backup destinations on the cPanel server?Solution :- Yes, its...

ERROR: There was an error connecting to the server, Please verify the settings

While updating the WordPress plugin using FTP client I was getting the error as -'ERROR: There...

How to allow remote MySql connection to only one IP?

There may be a case in which one of the cPanel user request you to provide access to Mysql...

Powered by WHMCompleteSolution