Required PHP version greater than equal to 5.4.45 AND found version is : 5.3.3

While installing application via Softaculous Application Installer it appears the following error message :
Required PHP version greater than equal to 5.4.45 AND found version is : 5.3.3.

Note : In this case the server has PHP 5.3.3 version and the script required higher version.

Solution :

1. Login to your server.
2. Rename the "pre_install.txt" file located in /usr/local/softaculous/enduser/hooks/ path to "pre_install.php".
3. Add below code to identify the PHP version and try to re-install the application -

function __pre_install(){
global $soft, $software, $globals;
// Do stuff here e.g. is as follows
$version = '5.4.45';
define('php_version', $version);

That's it!

Was this answer helpful?

 Print this Article

Also Read

How to install and configure the Mod Security on Plesk 12 admin?

Mod Security installer is used for preventing the attacks on web applications. Mod security will...

How to resolve POST request fails while adding the sub-domain?

While adding sub-domain, I'm facing issue with POST request. I tried adding sub-domain, server is...

Unable to connect FTP - Incorrect Password or User Account is disabled in Windows

Error - The domain's primary ftp user account is disabled in Windows or has an invalid password....

How to force Force postfix to use only IPv4 protocol?

Here are the steps to Force postfix to use only IPv4 protocol - 1. Open postfix configuration...

How to retrieve plesk panel admin password?

Steps to retrieve plesk panel admin password -For Plesk versions 10.x-12.x :Log in to server via...

Powered by WHMCompleteSolution